aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/lib/ar71xx.sh
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
commitd5ba886ca6de7dd6ea20fd8b3deb8a6675646826 (patch)
tree10c22d4fc3070cc5c70b6fe625d5e8c544f23e09 /target/linux/ar71xx/base-files/lib/ar71xx.sh
parent2830947555b70b6dd5a2da8f5d7d3db6b4903f52 (diff)
downloadupstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.gz
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.bz2
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to 15.05
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox to 15.05 Chaos Calmer. Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47235 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/base-files/lib/ar71xx.sh')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index f0c9ae1a06..6f5ff18df1 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -119,6 +119,9 @@ tplink_board_detect() {
"3C0001"*)
model="OOLITE"
;;
+ "3C0002"*)
+ model="MINIBOX_V1"
+ ;;
"070300"*)
model="TP-Link TL-WR703N"
;;
@@ -493,6 +496,9 @@ ar71xx_board_detect() {
*"MAC1200R")
name="mc-mac1200r"
;;
+ *"MiniBox V1.0")
+ name="minibox-v1"
+ ;;
*MR12)
name="mr12"
;;