aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/etc/diag.sh
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
commitd5ba886ca6de7dd6ea20fd8b3deb8a6675646826 (patch)
tree10c22d4fc3070cc5c70b6fe625d5e8c544f23e09 /target/linux/ar71xx/base-files/etc/diag.sh
parent2830947555b70b6dd5a2da8f5d7d3db6b4903f52 (diff)
downloadupstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.gz
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.bz2
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to 15.05
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox to 15.05 Chaos Calmer. Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47235 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/base-files/etc/diag.sh')
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 987e369328..9e3031345a 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -213,6 +213,9 @@ get_status_led() {
smart-300)
status_led="nc-link:green:system"
;;
+ minibox-v1)
+ status_led="minibox-v1:green:system"
+ ;;
oolite)
status_led="oolite:red:system"
;;