aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.6/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-11 18:41:09 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-11 18:41:09 +0000
commitb363a7e4918327119b812ada6641b21bd84e0e04 (patch)
treebf353b93ca5fb2a3fa6d47e8b6b7ee03fe928f17 /target/linux/ar7/patches-3.6/120-gpio_chrdev.patch
parent854c5047814d6eb446cc26b6b742cd6abe10e183 (diff)
downloadupstream-b363a7e4918327119b812ada6641b21bd84e0e04.tar.gz
upstream-b363a7e4918327119b812ada6641b21bd84e0e04.tar.bz2
upstream-b363a7e4918327119b812ada6641b21bd84e0e04.zip
add support for Linux 3.6
SVN-Revision: 34154
Diffstat (limited to 'target/linux/ar7/patches-3.6/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-3.6/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.6/120-gpio_chrdev.patch b/target/linux/ar7/patches-3.6/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..51716a3f5c
--- /dev/null
+++ b/target/linux/ar7/patches-3.6/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -463,6 +463,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -43,6 +43,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o