aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.3/110-flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:39 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:39 +0000
commit7b3873c7fbe48ca347149951bdd758908dd668f2 (patch)
treefb75d66cf5a2b2cd4e29989305bdc7fb621dbaa7 /target/linux/ar7/patches-3.3/110-flash.patch
parent2034dd105a5d0cfc371fb00eb7bfbfced18fb748 (diff)
downloadupstream-7b3873c7fbe48ca347149951bdd758908dd668f2.tar.gz
upstream-7b3873c7fbe48ca347149951bdd758908dd668f2.tar.bz2
upstream-7b3873c7fbe48ca347149951bdd758908dd668f2.zip
ar7: add 3.3 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31615 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-3.3/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-3.3/110-flash.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.3/110-flash.patch b/target/linux/ar7/patches-3.3/110-flash.patch
new file mode 100644
index 0000000000..58ce7eaa40
--- /dev/null
+++ b/target/linux/ar7/patches-3.3/110-flash.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/maps/physmap.c
++++ b/drivers/mtd/maps/physmap.c
+@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
+ "map_rom",
+ NULL };
+ static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
+- NULL };
++ "ar7part", NULL };
+
+ static int physmap_flash_probe(struct platform_device *dev)
+ {
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
++obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+