aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.18
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-10-12 10:51:53 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2017-10-29 23:41:00 +0100
commit23145d427613ee9b982cec25d187b41cc938f27a (patch)
treecb6e54b7be9d7922ac93db4324a623582cc35a4b /target/linux/ar7/patches-3.18
parentc77ba7df09564226b791ae693dc3cf3ad9d2385f (diff)
downloadupstream-23145d427613ee9b982cec25d187b41cc938f27a.tar.gz
upstream-23145d427613ee9b982cec25d187b41cc938f27a.tar.bz2
upstream-23145d427613ee9b982cec25d187b41cc938f27a.zip
ar7: remove gpio character device
There are no obvious users, and any out of tree users should convert to one of the generic APIs. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/ar7/patches-3.18')
-rw-r--r--target/linux/ar7/patches-3.18/120-gpio_chrdev.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch b/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
deleted file mode 100644
index beb0052ca1..0000000000
--- a/target/linux/ar7/patches-3.18/120-gpio_chrdev.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/char/Kconfig
-+++ b/drivers/char/Kconfig
-@@ -452,6 +452,15 @@ config MWAVE
- To compile this driver as a module, choose M here: the
- module will be called mwave.
-
-+config AR7_GPIO
-+ tristate "TI AR7 GPIO Support"
-+ depends on AR7
-+ help
-+ Give userspace access to the GPIO pins on the Texas Instruments AR7
-+ processors.
-+
-+ If compiled as a module, it will be called ar7_gpio.
-+
- config SCx200_GPIO
- tristate "NatSemi SCx200 GPIO Support"
- depends on SCx200
---- a/drivers/char/Makefile
-+++ b/drivers/char/Makefile
-@@ -42,6 +42,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
- obj-$(CONFIG_PPDEV) += ppdev.o
- obj-$(CONFIG_NWBUTTON) += nwbutton.o
- obj-$(CONFIG_NWFLASH) += nwflash.o
-+obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
- obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
- obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
- obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o