aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-09 12:12:30 +0000
committerJohn Crispin <john@openwrt.org>2015-02-09 12:12:30 +0000
commit9f0f80faacff55e9e909b87328fc0def14290562 (patch)
treecc7d2b74e9645ac723ef45db443ff6b4b0aeda14 /target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
parent5c8b8b36e1812feb055fc8574fe03156fa1efcb3 (diff)
downloadupstream-9f0f80faacff55e9e909b87328fc0def14290562.tar.gz
upstream-9f0f80faacff55e9e909b87328fc0def14290562.tar.bz2
upstream-9f0f80faacff55e9e909b87328fc0def14290562.zip
ar7: add 3.18 support
this is only compile tested Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44344
Diffstat (limited to 'target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch')
-rw-r--r--target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch b/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
new file mode 100644
index 0000000000..e6b08d669a
--- /dev/null
+++ b/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -169,6 +169,11 @@ config MTD_OF_PARTS
+ the partition map from the children of the flash node,
+ as described in Documentation/devicetree/booting-without-of.txt.
+
++config MTD_AC49X_PARTS
++ tristate "AudioCodes AC49X partitioning support"
++ ---help---
++ AudioCodes AC49X partitioning support
++
+ config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -15,6 +15,7 @@ mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsp
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
++obj-$(CONFIG_MTD_AC49X_PARTS) += ac49xpart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -202,7 +202,7 @@ static struct resource physmap_flash_res
+ .end = 0x11ffffff,
+ };
+
+-static const char *ar7_probe_types[] = { "ar7part", NULL };
++static const char *ar7_probe_types[] = { "ac49xpart", "ar7part", NULL };
+
+ static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,