aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.14/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-08 06:15:03 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-08 06:15:03 +0000
commit50dd026b10c4867b0248ea2effbe57af0ef54877 (patch)
treedef9f2a412218dcb234610df65d367d5b215b1da /target/linux/ar7/patches-3.14/120-gpio_chrdev.patch
parent12dc1f61db82b1588f0a782727f539eb51d04ef8 (diff)
downloadupstream-50dd026b10c4867b0248ea2effbe57af0ef54877.tar.gz
upstream-50dd026b10c4867b0248ea2effbe57af0ef54877.tar.bz2
upstream-50dd026b10c4867b0248ea2effbe57af0ef54877.zip
ar7: bump to 3.14
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-3.14/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-3.14/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.14/120-gpio_chrdev.patch b/target/linux/ar7/patches-3.14/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..15bc6c3efd
--- /dev/null
+++ b/target/linux/ar7/patches-3.14/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -464,6 +464,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -43,6 +43,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o