aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.14/110-flash.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-08 06:15:03 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-08 06:15:03 +0000
commit50dd026b10c4867b0248ea2effbe57af0ef54877 (patch)
treedef9f2a412218dcb234610df65d367d5b215b1da /target/linux/ar7/patches-3.14/110-flash.patch
parent12dc1f61db82b1588f0a782727f539eb51d04ef8 (diff)
downloadupstream-50dd026b10c4867b0248ea2effbe57af0ef54877.tar.gz
upstream-50dd026b10c4867b0248ea2effbe57af0ef54877.tar.bz2
upstream-50dd026b10c4867b0248ea2effbe57af0ef54877.zip
ar7: bump to 3.14
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-3.14/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-3.14/110-flash.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.14/110-flash.patch b/target/linux/ar7/patches-3.14/110-flash.patch
new file mode 100644
index 0000000000..e12eec5f7d
--- /dev/null
+++ b/target/linux/ar7/patches-3.14/110-flash.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -16,7 +16,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
++obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
+ .name = "mem",
+ .flags = IORESOURCE_MEM,
+ .start = 0x10000000,
+- .end = 0x107fffff,
++ .end = 0x11ffffff,
+ };
+
+ static const char *ar7_probe_types[] = { "ar7part", NULL };