aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-07 12:17:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-07 12:17:56 +0000
commit6239eb2c7bf24099a7516cef5bb14ca61b1a0a58 (patch)
treeb15c57cdf15ae7339d829b6d75d025035a599b49 /target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch
parent28dbc959ca75f6ca3c3f6a6c9295a5924dad469b (diff)
downloadupstream-6239eb2c7bf24099a7516cef5bb14ca61b1a0a58.tar.gz
upstream-6239eb2c7bf24099a7516cef5bb14ca61b1a0a58.tar.bz2
upstream-6239eb2c7bf24099a7516cef5bb14ca61b1a0a58.zip
update to 2.6.27 (#4122)
SVN-Revision: 15665
Diffstat (limited to 'target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch b/target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..dfda2310e2
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -960,6 +960,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -91,6 +91,7 @@ obj-$(CONFIG_COBALT_LCD) += lcd.o
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o