aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.23
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-10-05 17:54:36 +0000
committerEugene Konev <ejka@imfi.kspu.ru>2007-10-05 17:54:36 +0000
commit3c4062a45f764d064fb176f98ba3a8f1c1d41e4f (patch)
treeed6bf58ed3c3e2f42cf1a2fa5464ad2979d0593f /target/linux/ar7/patches-2.6.23
parentbcdd5d9b14847fef0cb566c0022d4cd1919a8ee5 (diff)
downloadupstream-3c4062a45f764d064fb176f98ba3a8f1c1d41e4f.tar.gz
upstream-3c4062a45f764d064fb176f98ba3a8f1c1d41e4f.tar.bz2
upstream-3c4062a45f764d064fb176f98ba3a8f1c1d41e4f.zip
cleanup vlynq. drop vlynq-pci
SVN-Revision: 9143
Diffstat (limited to 'target/linux/ar7/patches-2.6.23')
-rw-r--r--target/linux/ar7/patches-2.6.23/100-board_support.patch3
-rw-r--r--target/linux/ar7/patches-2.6.23/130-vlynq.patch20
2 files changed, 21 insertions, 2 deletions
diff --git a/target/linux/ar7/patches-2.6.23/100-board_support.patch b/target/linux/ar7/patches-2.6.23/100-board_support.patch
index c3da71b267..9269a13a30 100644
--- a/target/linux/ar7/patches-2.6.23/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.23/100-board_support.patch
@@ -2,7 +2,7 @@ Index: linux-2.6.23-rc6/arch/mips/Kconfig
===================================================================
--- linux-2.6.23-rc6.orig/arch/mips/Kconfig 2007-09-21 16:23:51.000000000 +0800
+++ linux-2.6.23-rc6/arch/mips/Kconfig 2007-09-21 16:24:11.000000000 +0800
-@@ -15,6 +15,23 @@
+@@ -15,6 +15,22 @@
prompt "System type"
default SGI_IP22
@@ -10,7 +10,6 @@ Index: linux-2.6.23-rc6/arch/mips/Kconfig
+ bool "Texas Instruments AR7"
+ select BOOT_ELF32
+ select DMA_NONCOHERENT
-+ select HW_HAS_PCI
+ select IRQ_CPU
+ select NO_EXCEPT_FILL
+ select SWAP_IO_SPACE
diff --git a/target/linux/ar7/patches-2.6.23/130-vlynq.patch b/target/linux/ar7/patches-2.6.23/130-vlynq.patch
new file mode 100644
index 0000000000..6cdb4df985
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.23/130-vlynq.patch
@@ -0,0 +1,20 @@
+Index: linux-2.6.23-rc9/drivers/Kconfig
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/Kconfig 2007-10-05 20:47:14.000000000 +0800
++++ linux-2.6.23-rc9/drivers/Kconfig 2007-10-05 20:47:42.000000000 +0800
+@@ -89,4 +89,6 @@
+ source "drivers/uio/Kconfig"
+
+ source "drivers/lguest/Kconfig"
++
++source "drivers/vlynq/Kconfig"
+ endmenu
+Index: linux-2.6.23-rc9/drivers/Makefile
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/Makefile 2007-10-05 20:47:09.000000000 +0800
++++ linux-2.6.23-rc9/drivers/Makefile 2007-10-05 20:47:30.000000000 +0800
+@@ -88,3 +88,4 @@
+ obj-$(CONFIG_HID) += hid/
+ obj-$(CONFIG_PPC_PS3) += ps3/
+ obj-$(CONFIG_OF) += of/
++obj-$(CONFIG_VLYNQ) += vlynq/