aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.22/100-board_support.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2007-09-11 23:50:02 +0000
committerMatteo Croce <rootkit85@yahoo.it>2007-09-11 23:50:02 +0000
commit09b45caf093366be331e166fb51f7626a3db5391 (patch)
tree07feeecda3bc87ae6a7fa0bb638f65ddbdd67e48 /target/linux/ar7/patches-2.6.22/100-board_support.patch
parent1349562f8d7da4439ac6f724750edce3899f65f2 (diff)
downloadupstream-09b45caf093366be331e166fb51f7626a3db5391.tar.gz
upstream-09b45caf093366be331e166fb51f7626a3db5391.tar.bz2
upstream-09b45caf093366be331e166fb51f7626a3db5391.zip
more AR7 cleanups & fixes
SVN-Revision: 8758
Diffstat (limited to 'target/linux/ar7/patches-2.6.22/100-board_support.patch')
-rw-r--r--target/linux/ar7/patches-2.6.22/100-board_support.patch30
1 files changed, 12 insertions, 18 deletions
diff --git a/target/linux/ar7/patches-2.6.22/100-board_support.patch b/target/linux/ar7/patches-2.6.22/100-board_support.patch
index 0a226f52e5..ee86a14304 100644
--- a/target/linux/ar7/patches-2.6.22/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.22/100-board_support.patch
@@ -26,37 +26,31 @@ diff -urN linux-2.6.22/arch/mips/Kconfig linux-2.6.22.new/arch/mips/Kconfig
diff -urN linux-2.6.22/arch/mips/kernel/traps.c linux-2.6.22.new/arch/mips/kernel/traps.c
--- linux-2.6.22/arch/mips/kernel/traps.c 2007-07-09 01:32:17.000000000 +0200
+++ linux-2.6.22.new/arch/mips/kernel/traps.c 2007-07-11 02:32:39.000000000 +0200
-@@ -1051,11 +1051,6 @@
- unsigned long exception_handlers[32];
- unsigned long vi_handlers[64];
-
--/*
-- * As a side effect of the way this is implemented we're limited
-- * to interrupt handlers in the address range from
-- * KSEG0 <= x < KSEG0 + 256mb on the Nevada. Oh well ...
-- */
- void *set_except_vector(int n, void *addr)
- {
- unsigned long handler = (unsigned long) addr;
-@@ -1063,9 +1058,15 @@
+@@ -1075,9 +1075,23 @@ void *set_except_vector(int n, void *addr)
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
-- *(volatile u32 *)(ebase + 0x200) = 0x08000000 |
-- (0x03ffffff & (handler >> 2));
-- flush_icache_range(ebase + 0x200, ebase + 0x204);
++#ifdef CONFIG_AR7
+ /* lui k0, 0x0000 */
-+ *(volatile u32 *)(CAC_BASE+0x200) = 0x3c1a0000 | (handler >> 16);
++ *(volatile u32 *)(CAC_BASE+0x200) =
++ 0x3c1a0000 | (handler >> 16);
+ /* ori k0, 0x0000 */
-+ *(volatile u32 *)(CAC_BASE+0x204) = 0x375a0000 | (handler & 0xffff);
++ *(volatile u32 *)(CAC_BASE+0x204) =
++ 0x375a0000 | (handler & 0xffff);
+ /* jr k0 */
+ *(volatile u32 *)(CAC_BASE+0x208) = 0x03400008;
+ /* nop */
+ *(volatile u32 *)(CAC_BASE+0x20C) = 0x00000000;
+ flush_icache_range(CAC_BASE+0x200, CAC_BASE+0x210);
++#else
+ *(volatile u32 *)(ebase + 0x200) = 0x08000000 |
+ (0x03ffffff & (handler >> 2));
+ flush_icache_range(ebase + 0x200, ebase + 0x204);
++#endif
}
return (void *)old_handler;
}
+
diff -urN linux-2.6.22/arch/mips/Makefile linux-2.6.22.new/arch/mips/Makefile
--- linux-2.6.22/arch/mips/Makefile 2007-07-09 01:32:17.000000000 +0200
+++ linux-2.6.22.new/arch/mips/Makefile 2007-07-11 02:32:39.000000000 +0200