aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.6/base-files.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-20 15:16:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-20 15:16:51 +0000
commit36802e23cf892c0a3cb551a4efd7779d8fadab6f (patch)
treea67dda483d549a241f15875aa996350daa993ce7 /target/linux/ar7-2.6/base-files.mk
parentb0aadf9bbfea6dc95b4355caabf5dfe83ef3718b (diff)
downloadupstream-36802e23cf892c0a3cb551a4efd7779d8fadab6f.tar.gz
upstream-36802e23cf892c0a3cb551a4efd7779d8fadab6f.tar.bz2
upstream-36802e23cf892c0a3cb551a4efd7779d8fadab6f.zip
copy adam2 patch from ar7-2.4 to ar7-2.6
SVN-Revision: 7014
Diffstat (limited to 'target/linux/ar7-2.6/base-files.mk')
-rw-r--r--target/linux/ar7-2.6/base-files.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar7-2.6/base-files.mk b/target/linux/ar7-2.6/base-files.mk
new file mode 100644
index 0000000000..f21a604b83
--- /dev/null
+++ b/target/linux/ar7-2.6/base-files.mk
@@ -0,0 +1,11 @@
+define Build/Compile
+ $(call Build/Compile/Default)
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/adam2patcher $(PLATFORM_DIR)/src/adam2patcher.c
+endef
+
+define Package/base-files/install-target
+ mkdir -p $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/adam2patcher $(1)/sbin
+endef
+
+