aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.4/Makefile
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/ar7-2.4/Makefile
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadupstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
upstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
upstream-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/ar7-2.4/Makefile')
-rw-r--r--target/linux/ar7-2.4/Makefile19
1 files changed, 2 insertions, 17 deletions
diff --git a/target/linux/ar7-2.4/Makefile b/target/linux/ar7-2.4/Makefile
index 970bb4bbdf..87c2470205 100644
--- a/target/linux/ar7-2.4/Makefile
+++ b/target/linux/ar7-2.4/Makefile
@@ -20,22 +20,7 @@ KERNEL:=2.4
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-avalanche-cpmac
-define Profile/AnnexA
- NAME:=ADSL Annex A (default)
- PACKAGES:=kmod-sangam-atm-annex-a ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexA))
-
-define Profile/AnnexB
- NAME:=ADSL Annex B
- PACKAGES:=kmod-sangam-atm-annex-b ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexB))
-
-define Profile/None
- NAME:=No ADSL
- PACKAGES:=
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))