aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-12-27 20:44:11 -0800
committerPaul Spooren <mail@aparcar.org>2023-02-04 02:35:03 +0100
commit2630e5063df0240eb0d05cd6e953b2bd412e3215 (patch)
treec420021efd2ad444bf7e4f9e83675fdd43ae483e /target/linux/apm821xx
parent19988b66d07f44be757c4a0e41be899dbf8c72dd (diff)
downloadupstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.gz
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.bz2
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.zip
treewide: replace wpad-basic-wolfssl default
The newly merged mbedtls backend is smaller and has fewer ABI related issues than the wolfSSL one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/sata.mk2
-rw-r--r--target/linux/apm821xx/nand/target.mk2
-rw-r--r--target/linux/apm821xx/sata/profiles/00-default.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/apm821xx/image/sata.mk b/target/linux/apm821xx/image/sata.mk
index 40bd2807c9..89af488e09 100644
--- a/target/linux/apm821xx/image/sata.mk
+++ b/target/linux/apm821xx/image/sata.mk
@@ -8,7 +8,7 @@ define Device/wd_mybooklive
DEVICE_MODEL := My Book Live
DEVICE_ALT0_VENDOR := Western Digital
DEVICE_ALT0_MODEL := My Book Live Duo
- DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-wolfssl
+ DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-mbedtls
SUPPORTED_DEVICES += mbl wd,mybooklive-duo
BLOCKSIZE := 1k
DTB_SIZE := 16384
diff --git a/target/linux/apm821xx/nand/target.mk b/target/linux/apm821xx/nand/target.mk
index 208ea10b91..0cba949fa0 100644
--- a/target/linux/apm821xx/nand/target.mk
+++ b/target/linux/apm821xx/nand/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Devices with NAND flash (Routers)
FEATURES += nand pcie
-DEFAULT_PACKAGES += kmod-ath9k swconfig wpad-basic-wolfssl
+DEFAULT_PACKAGES += kmod-ath9k swconfig wpad-basic-mbedtls
define Target/Description
Build firmware images for APM821XX boards with NAND flash.
diff --git a/target/linux/apm821xx/sata/profiles/00-default.mk b/target/linux/apm821xx/sata/profiles/00-default.mk
index a203821533..082068fe36 100644
--- a/target/linux/apm821xx/sata/profiles/00-default.mk
+++ b/target/linux/apm821xx/sata/profiles/00-default.mk
@@ -5,7 +5,7 @@
define Profile/Default
NAME:=Default Profile
PRIORITY:=1
- PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-wolfssl
+ PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-mbedtls
endef
define Profile/Default/Description