aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/sata
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-29 11:55:15 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 08:11:56 +0200
commitaed4799d6d05d89dbca1bd5f14cc3d09ac563f3b (patch)
treee25dae8904f5ae669c619e623bc854666fe5e0de /target/linux/apm821xx/sata
parent7516a960113d512cb2909f40bd07caf2a6c547b1 (diff)
downloadupstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.tar.gz
upstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.tar.bz2
upstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.zip
apm821xx: build squashfs-rootfs images for the MBL
This patch adds support for squashfs as the root filesystem. advantages: - migrate from a existing -ext4 installation and back with the sysupgrade utility - existing partition layout will not be lost during switch - slightly smaller image size as compared to the -ext4 image. disadvantages: - needs f2fs + tools. This is because fstools rootdisk.c decides based on the partition size (currently root partitions > 100 MiB) f2fs is used as the rootfs_data filesystem. - rootfs_data is placed into the rootfs partition after the squashfs. This makes it difficult for tools that expect a /dev/sda${X} device. It also makes it difficult for data recovery tools as they might not expect to find a embedded partition or will be slightly confused. ... or will not support f2fs. For people with existing build configurations: make sure to include mkf2fs and f2fsck packages into the image. Otherwise the new -squashfs image will only boot from the ram-overlay. Note: All overlay data (configurations/all installed packages/...) will be placed in inside the rootfs partition (i.e. /dev/sda2) just after the squashfs image. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/sata')
-rw-r--r--target/linux/apm821xx/sata/config-default6
-rw-r--r--target/linux/apm821xx/sata/target.mk4
2 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/apm821xx/sata/config-default b/target/linux/apm821xx/sata/config-default
index 7ca6bd4d3d..4c7c655233 100644
--- a/target/linux/apm821xx/sata/config-default
+++ b/target/linux/apm821xx/sata/config-default
@@ -16,6 +16,11 @@ CONFIG_GENERIC_PHY=y
CONFIG_SATA_DWC=y
# CONFIG_SATA_DWC_DEBUG is not set
CONFIG_EXT4_FS=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_SCSI=y
CONFIG_BLK_DEV_SD=y
CONFIG_GPIOLIB=y
@@ -23,6 +28,7 @@ CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_GENERIC_PLATFORM=y
CONFIG_GPIO_74XX_MMIO=y
CONFIG_LEDS_TRIGGER_DISK=y
+CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_DM=y
CONFIG_BLK_DEV_DM_BUILTIN=y
CONFIG_BLK_DEV_MD=y
diff --git a/target/linux/apm821xx/sata/target.mk b/target/linux/apm821xx/sata/target.mk
index 1c7856828c..a5107f1067 100644
--- a/target/linux/apm821xx/sata/target.mk
+++ b/target/linux/apm821xx/sata/target.mk
@@ -1,7 +1,7 @@
BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb ramdisk
+FEATURES += ext4 usb ramdisk squashfs
DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
- kmod-dm kmod-md-mod partx-utils
+ kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck
define Target/Description
Build firmware images for APM82181 boards that boot from SATA.