aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-11-30 20:57:11 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commite1e6ff6648f5a0819a5b9429e787c1b6aacfec59 (patch)
tree09a3af7fa01c7fb17a32b0e6b8bcba78f4d619a9 /target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
parent69d179ec81dacf92e1f693783c4ddcbf5a68b231 (diff)
downloadupstream-e1e6ff6648f5a0819a5b9429e787c1b6aacfec59.tar.gz
upstream-e1e6ff6648f5a0819a5b9429e787c1b6aacfec59.tar.bz2
upstream-e1e6ff6648f5a0819a5b9429e787c1b6aacfec59.zip
apm821xx: add linux kernel 5.4 testing support
This patch adds support for the linux kernel version 5.4 as an optional testing kernel. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch')
-rw-r--r--target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch b/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
new file mode 100644
index 0000000000..536a74ef00
--- /dev/null
+++ b/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
@@ -0,0 +1,32 @@
+--- a/arch/powerpc/platforms/44x/Makefile
++++ b/arch/powerpc/platforms/44x/Makefile
+@@ -4,6 +4,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
+ obj-y += idle.o
+ endif
+ obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
++obj-$(CONFIG_WNDR4700) += wndr4700.o
+ obj-$(CONFIG_EBONY) += ebony.o
+ obj-$(CONFIG_SAM440EP) += sam440ep.o
+ obj-$(CONFIG_WARP) += warp.o
+--- a/arch/powerpc/platforms/44x/Kconfig
++++ b/arch/powerpc/platforms/44x/Kconfig
+@@ -260,6 +260,19 @@ config ICON
+ help
+ This option enables support for the AMCC PPC440SPe evaluation board.
+
++config WNDR4700
++ bool "WNDR4700"
++ depends on 44x
++ default n
++ select APM821xx
++ select PCI_MSI
++ select PPC4xx_MSI
++ select PPC4xx_PCI_EXPRESS
++ select IBM_EMAC_RGMII
++ select 460EX
++ help
++ This option enables support for the Netgear WNDR4700/WNDR4720 board.
++
+ config XILINX_VIRTEX440_GENERIC_BOARD
+ bool "Generic Xilinx Virtex 5 FXT board support"
+ depends on 44x