aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-05 18:16:25 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 16:27:27 +0200
commitb2c9c4dda28dd9bd82df629d96d626d2c236f382 (patch)
tree55979d041024180e818603f0d7e5ae1ee47ccbe1 /target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch
parentfd836f3d15fdfcb15b8b94303d102cb1e37f53ba (diff)
downloadupstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.tar.gz
upstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.tar.bz2
upstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.zip
apm821xx: add support for kernel 5.15 for testing
This patch copies over refreshed config and patches from 5.10 with the following changes: - dropped superfluous tc654/tc655 variant detection patch (tc654 support will become available upstream starting with 5.17-rc7+). - dropped xhci msi(x) workaround... as the broken MSI(X) is now gone. - dropped dwc2 workaround since the driver was fixed and it works without it. Please note: Netgear WNDAP660 & WNDAP620 users: Due to the kernel's size increase, uboot will likely break because it is overwrite the kernel during decompression. To fix this (and debrick affected devices, no reflash necessary), attach the RJ45-Serial-Console cable and enter the following in the uboot prompt during bootup: setenv kernel_addr_r 1100000 saveenv run bootcmd to restore the old/previous behavior: setenv kernel_addr_r 600000 saveenv run bootcmd Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch')
-rw-r--r--target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch b/target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch
new file mode 100644
index 0000000000..3a9f48d0ab
--- /dev/null
+++ b/target/linux/apm821xx/patches-5.15/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch
@@ -0,0 +1,29 @@
+From c9395ad54e2cabb87d408becc37566f3d8248933 Mon Sep 17 00:00:00 2001
+From: Christian Lamparter <chunkeey@gmail.com>
+Date: Sun, 1 Dec 2019 02:08:23 +0100
+Subject: [PATCH] powerpc: bootwrapper: force gzip as mkimage's compression
+ method
+
+Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
+instruct the mkimage to use the xz compression, which isn't
+supported. This patch forces the gzip compression, which is
+supported and doesn't matter because the generated uImage for
+the apm821xx target gets ignored as the OpenWrt toolchain will
+do separate U-Boot kernel images for each device individually.
+
+Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
+---
+ arch/powerpc/boot/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -257,7 +257,7 @@ compressor-$(CONFIG_KERNEL_LZO) := lzo
+
+ # args (to if_changed): 1 = (this rule), 2 = platform, 3 = dts 4=dtb 5=initrd
+ quiet_cmd_wrap = WRAP $@
+- cmd_wrap =$(CONFIG_SHELL) $(wrapper) -Z $(compressor-y) -c -o $@ -p $2 \
++ cmd_wrap =$(CONFIG_SHELL) $(wrapper) -Z gzip -c -o $@ -p $2 \
+ $(CROSSWRAP) $(if $3, -s $3)$(if $4, -d $4)$(if $5, -i $5) \
+ vmlinux
+