aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2017-02-10 17:44:43 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-11 20:57:56 +0100
commit9a9f2f97e6b66cc88866b3522372d4caa59b26de (patch)
treef05b66ca99f795a300efd2cea7b6dce0df8b365a /target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch
parent9827c3e9b9d366be2edc8f1d27a1b84d03cfa97d (diff)
downloadupstream-9a9f2f97e6b66cc88866b3522372d4caa59b26de.tar.gz
upstream-9a9f2f97e6b66cc88866b3522372d4caa59b26de.tar.bz2
upstream-9a9f2f97e6b66cc88866b3522372d4caa59b26de.zip
apm821xx: add linux 4.9 apm821xx patches
This patch updates the apm821xx target to use the 4.9 kernel. Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
Diffstat (limited to 'target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch')
-rw-r--r--target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch b/target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch
new file mode 100644
index 0000000000..6b6db1dddb
--- /dev/null
+++ b/target/linux/apm821xx/patches-4.9/202-add-netgear-wndr4700-support.patch
@@ -0,0 +1,32 @@
+--- a/arch/powerpc/platforms/44x/Makefile
++++ b/arch/powerpc/platforms/44x/Makefile
+@@ -3,6 +3,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
+ obj-$(CONFIG_44x) += idle.o
+ endif
+ obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
++obj-$(CONFIG_WNDR4700) += wndr4700.o
+ obj-$(CONFIG_EBONY) += ebony.o
+ obj-$(CONFIG_SAM440EP) += sam440ep.o
+ obj-$(CONFIG_WARP) += warp.o
+--- a/arch/powerpc/platforms/44x/Kconfig
++++ b/arch/powerpc/platforms/44x/Kconfig
+@@ -260,6 +260,19 @@ config ICON
+ help
+ This option enables support for the AMCC PPC440SPe evaluation board.
+
++config WNDR4700
++ bool "WNDR4700"
++ depends on 44x
++ default n
++ select APM821xx
++ select PCI_MSI
++ select PPC4xx_MSI
++ select PPC4xx_PCI_EXPRESS
++ select IBM_EMAC_RGMII
++ select 460EX
++ help
++ This option enables support for the Netgear WNDR4700/WNDR4720 board.
++
+ config XILINX_VIRTEX440_GENERIC_BOARD
+ bool "Generic Xilinx Virtex 5 FXT board support"
+ depends on 44x