aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-09-30 11:40:13 +0200
committerChristian Lamparter <chunkeey@gmail.com>2018-12-27 14:36:23 +0100
commit32141c183a28a55fd3288397348ca820b77265d3 (patch)
tree04e7b6b8c5978a6362a0c519a990ac0441c54a40 /target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch
parent96d55f9fd990beed06b79a65100ef7c942dc125d (diff)
downloadupstream-32141c183a28a55fd3288397348ca820b77265d3.tar.gz
upstream-32141c183a28a55fd3288397348ca820b77265d3.tar.bz2
upstream-32141c183a28a55fd3288397348ca820b77265d3.zip
apm821xx: add linux 4.19 apm821xx patches
This patch updates the apm821xx target to use the 4.19 kernel. 4.19 ships with all the crypto4xx driver patches. Furthermore, the DW-DMA fix for the SATA controller has been backported from 4.20 and integrated. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch')
-rw-r--r--target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch b/target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch
new file mode 100644
index 0000000000..77294a8cbd
--- /dev/null
+++ b/target/linux/apm821xx/patches-4.19/202-add-netgear-wndr4700-support.patch
@@ -0,0 +1,32 @@
+--- a/arch/powerpc/platforms/44x/Makefile
++++ b/arch/powerpc/platforms/44x/Makefile
+@@ -4,6 +4,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
+ obj-y += idle.o
+ endif
+ obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
++obj-$(CONFIG_WNDR4700) += wndr4700.o
+ obj-$(CONFIG_EBONY) += ebony.o
+ obj-$(CONFIG_SAM440EP) += sam440ep.o
+ obj-$(CONFIG_WARP) += warp.o
+--- a/arch/powerpc/platforms/44x/Kconfig
++++ b/arch/powerpc/platforms/44x/Kconfig
+@@ -273,6 +273,19 @@ config ICON
+ help
+ This option enables support for the AMCC PPC440SPe evaluation board.
+
++config WNDR4700
++ bool "WNDR4700"
++ depends on 44x
++ default n
++ select APM821xx
++ select PCI_MSI
++ select PPC4xx_MSI
++ select PPC4xx_PCI_EXPRESS
++ select IBM_EMAC_RGMII
++ select 460EX
++ help
++ This option enables support for the Netgear WNDR4700/WNDR4720 board.
++
+ config XILINX_VIRTEX440_GENERIC_BOARD
+ bool "Generic Xilinx Virtex 5 FXT board support"
+ depends on 44x