aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-01-07 21:27:48 +0100
committerMathias Kresin <dev@kresin.me>2018-01-12 08:00:04 +0100
commit15faf389ad5159fa8223344029c98a0afca6e5ef (patch)
tree68e652f9cd4ff7753620d9a8882643e3a8a85077 /target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch
parent9a9c7fb4cf8a0483b26b2d9ecc481275173d63f7 (diff)
downloadupstream-15faf389ad5159fa8223344029c98a0afca6e5ef.tar.gz
upstream-15faf389ad5159fa8223344029c98a0afca6e5ef.tar.bz2
upstream-15faf389ad5159fa8223344029c98a0afca6e5ef.zip
apm821xx: add linux 4.14 apm821xx patches
This patch updates the apm821xx target to use the 4.14 kernel. 4.14 finally ships with a driver for the WNDR4700's tc654 fan controller. The custom driver is deprecated in favor of the upstream driver and the thermal cooling definitions in the DTS are updated. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch')
-rw-r--r--target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch b/target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch
new file mode 100644
index 0000000000..77294a8cbd
--- /dev/null
+++ b/target/linux/apm821xx/patches-4.14/202-add-netgear-wndr4700-support.patch
@@ -0,0 +1,32 @@
+--- a/arch/powerpc/platforms/44x/Makefile
++++ b/arch/powerpc/platforms/44x/Makefile
+@@ -4,6 +4,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
+ obj-y += idle.o
+ endif
+ obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
++obj-$(CONFIG_WNDR4700) += wndr4700.o
+ obj-$(CONFIG_EBONY) += ebony.o
+ obj-$(CONFIG_SAM440EP) += sam440ep.o
+ obj-$(CONFIG_WARP) += warp.o
+--- a/arch/powerpc/platforms/44x/Kconfig
++++ b/arch/powerpc/platforms/44x/Kconfig
+@@ -273,6 +273,19 @@ config ICON
+ help
+ This option enables support for the AMCC PPC440SPe evaluation board.
+
++config WNDR4700
++ bool "WNDR4700"
++ depends on 44x
++ default n
++ select APM821xx
++ select PCI_MSI
++ select PPC4xx_MSI
++ select PPC4xx_PCI_EXPRESS
++ select IBM_EMAC_RGMII
++ select 460EX
++ help
++ This option enables support for the Netgear WNDR4700/WNDR4720 board.
++
+ config XILINX_VIRTEX440_GENERIC_BOARD
+ bool "Generic Xilinx Virtex 5 FXT board support"
+ depends on 44x