aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-10-03 00:19:58 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-10 16:44:15 +0200
commit7a6a3494450c4e3a41dd8cc8f3cadb525d5e966b (patch)
tree41467e4da2c5c7c83e78307a65db238cf35f6b04 /target/linux/apm821xx/image
parent4ee9b3f462166f179f18e10b7b2e6f655473bb05 (diff)
downloadupstream-7a6a3494450c4e3a41dd8cc8f3cadb525d5e966b.tar.gz
upstream-7a6a3494450c4e3a41dd8cc8f3cadb525d5e966b.tar.bz2
upstream-7a6a3494450c4e3a41dd8cc8f3cadb525d5e966b.zip
apm821xx: WNDAP620 + WNDAP660: reorganize partitions for 5.10
Due to 5.10 increased kernel size, the current 4MiB-ish kernel partition got too small. Luckily, netgear's uboot environment is setup to read 0x60000 bytes from the kernel partition location. ... While at it: also do some cleanups in the DTS in there. The original (re-)installation described in commit d82d84694e60 ("apm821xx: add support for the Netgear WNDAP620 and WNDAP660") seemed to be still working for now. What I noticed though is that the bigger initramfs images needed to use a different destination address (1000000) to prevent it overwriting itself during decompression. i.e: # tftp 1000000 openwrt-...-wndap620-initramfs-kernel.bin # bootm However, in case of the WNDAP620+660 the factory.img image can be written directly to the flash through uboot. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image')
-rw-r--r--target/linux/apm821xx/image/nand.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/nand.mk b/target/linux/apm821xx/image/nand.mk
index 26676c8d8b..76b1386241 100644
--- a/target/linux/apm821xx/image/nand.mk
+++ b/target/linux/apm821xx/image/nand.mk
@@ -68,11 +68,14 @@ define Device/netgear_wndap6x0
DTB_SIZE := 32768
IMAGE_SIZE := 27392k
IMAGES := sysupgrade.bin factory.img
- KERNEL_SIZE := 4032k
+ KERNEL_SIZE := 6080k
KERNEL := dtb | kernel-bin | gzip | MuImage-initramfs gzip
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
UBINIZE_OPTS := -E 5
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := kernel and ubi partitions had to be resized. \
+ Upgrade via sysupgrade mechanism is not possible.
endef
define Device/netgear_wndap620