aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-07-20 15:44:54 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commitdc7efaefb53d4671893add07934839eb8d44934d (patch)
tree712375d1b97a8cea26ce5a97ac5cff14146937a3 /target/linux/apm821xx/image/Makefile
parentd37d16488c7f41306daf0d6bc6ba948b3ee547a5 (diff)
downloadupstream-dc7efaefb53d4671893add07934839eb8d44934d.tar.gz
upstream-dc7efaefb53d4671893add07934839eb8d44934d.tar.bz2
upstream-dc7efaefb53d4671893add07934839eb8d44934d.zip
apm821xx: add support for the Western Digital MyBook Live Series
Hardware Highlights: This patch adds support for Western Digital MyBook Live Series: CPU: AMCC PowerPC UNKNOWN (PVR=12c41c83) at 800 MHz (PLB=200, OPB=100, EBC=100 MHz) 32 kB I-Cache 32 kB D-Cache, 256 kB L2-Cache, 32 kB OnChip Memory Board: Apollo-3G - APM82181 Board, 1*SATA DRAM: 256 MB (2x NT5TU64M16GG-AC) FLASH: 512 kB (SST 39VF040) Ethernet: 1xRGMII - 1 Gbit - Broadcom PHY BCM54610 WARNING: The serial port needs a TTL/RS-232 v3.3 level converter! The MyBook Live Duo additionally features a 1x USB 2.0 host port and can support a second hard-drive. This target produces two images for a target. 1. ext4 image The extracted/raw image can be directly installed on the internal HDD via "dd if=img.ext4 of=/dev/sdX". This can either be done in place with the stock MyBook Live firmware via ssh. Or by removing the HDD and writing the image with a different PC. The the compressed images are useful for sysupgrade. 2. recovery.tar image for TFTP and Serial. extract the recovery.tar to a TFTP server directory. On the MyBook Live (Duo) serial port - Hit Enter during u-boot and insert: # setenv serverip 192.168.1.254; setenv ipaddr 192.168.1.1; run net_self Where 192.168.1.254 is your TFTP server. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile83
1 files changed, 82 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index ba11bb22ee..9ba43d9db2 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -78,6 +78,87 @@ define Device/mr24
endef
TARGET_DEVICES += mr24
-$(eval $(call BuildImage))
+endif
+
+ifeq ($(SUBTARGET),sata)
+
+### Image scripts for the WD My Book Live Series ###
+define Build/boot-script
+ $(STAGING_DIR_HOST)/bin/mkimage -A powerpc -T script -C none -n "$(PROFILE) Boot Script" \
+ -d mbl_boot.scr \
+ $@.scr
+endef
+
+define Build/boot-img
+ $(RM) -rf $@.bootdir
+ mkdir -p $@.bootdir/boot
+
+ $(CP) $@.scr $@.bootdir/boot/boot.scr
+ $(CP) $@.dtb $@.bootdir/boot/$(DEVICE_DTB)
+ $(CP) $(word 1,$^) $@.bootdir/boot/uImage
+
+ genext2fs --block-size $(BLOCKSIZE) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+
+ # convert it to revision 1 - needed for u-boot ext2load
+ $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
+ $(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.boot > /dev/null
+endef
+
+define Build/hdd-img
+ ./mbl_gen_hdd_img.sh $@ $@.boot $(word 2,$^)
+ $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
+endef
+
+define Build/uRamdisk
+ $(call Image/mkfs/ext4)
+ gzip -9n -c $(KDIR)/root.ext4 > $(KDIR)/root.ext4.gz
+ $(STAGING_DIR_HOST)/bin/mkimage -A powerpc -T ramdisk -C gzip -n "$(PROFILE) rootfs" \
+ -d $(KDIR)/root.ext4.gz \
+ $@.uRamdisk
+endef
+
+define Build/recovery-tar
+ sh ./mbl_gen_recovery_tar.sh \
+ --profile $(DEVICE_PROFILE) \
+ --dtb $@.dtb \
+ --dtbname $(DEVICE_DTB) \
+ --kernel $@ \
+ --rootfs $@.uRamdisk \
+ $@
+endef
+
+define Device/MyBookLiveDefault
+ IMAGE_SIZE := 48m
+ BLOCKSIZE := 1024
+ DTB_SIZE := 16384
+ KERNEL := kernel-bin | gzip | uImage gzip
+ BOOT_SIZE := 8
+ IMAGES := rootfs.img recovery.tar
+ DEVICE_DTB := apollo3g.dtb
+ IMAGE/rootfs.img := boot-script | dtb | boot-img | hdd-img
+ IMAGE/recovery.tar := kernel-bin | dtb | uRamdisk | recovery-tar
+endef
+
+define Device/MyBookLiveSingle
+$(Device/MyBookLiveDefault)
+ DEVICE_TITLE := Western Digital My Book Live
+ DEVICE_DTS := apollo3g
+ DEVICE_PROFILE := apollo3g
+endef
+
+TARGET_DEVICES += MyBookLiveSingle
+
+define Device/MyBookLiveDuo
+$(Device/MyBookLiveDefault)
+ DEVICE_TITLE := Western Digital My Book Live Duo
+ DEVICE_PACKAGES := kmod-usb-dwc2 kmod-ledtrig-usbdev kmod-usb-storage kmod-fs-vfat wpad-mini
+ DEVICE_DTS := apollo3g-duo
+ DEVICE_PROFILE := ap2nc
+endef
+
+TARGET_DEVICES += MyBookLiveDuo
endif
+
+$(eval $(call BuildImage))
+