aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-05 18:16:25 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 16:27:27 +0200
commitb2c9c4dda28dd9bd82df629d96d626d2c236f382 (patch)
tree55979d041024180e818603f0d7e5ae1ee47ccbe1 /target/linux/apm821xx/Makefile
parentfd836f3d15fdfcb15b8b94303d102cb1e37f53ba (diff)
downloadupstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.tar.gz
upstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.tar.bz2
upstream-b2c9c4dda28dd9bd82df629d96d626d2c236f382.zip
apm821xx: add support for kernel 5.15 for testing
This patch copies over refreshed config and patches from 5.10 with the following changes: - dropped superfluous tc654/tc655 variant detection patch (tc654 support will become available upstream starting with 5.17-rc7+). - dropped xhci msi(x) workaround... as the broken MSI(X) is now gone. - dropped dwc2 workaround since the driver was fixed and it works without it. Please note: Netgear WNDAP660 & WNDAP620 users: Due to the kernel's size increase, uboot will likely break because it is overwrite the kernel during decompression. To fix this (and debrick affected devices, no reflash necessary), attach the RJ45-Serial-Console cable and enter the following in the uboot prompt during bootup: setenv kernel_addr_r 1100000 saveenv run bootcmd to restore the old/previous behavior: setenv kernel_addr_r 600000 saveenv run bootcmd Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/Makefile')
-rw-r--r--target/linux/apm821xx/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
index 7d31ac8d67..f36274bd98 100644
--- a/target/linux/apm821xx/Makefile
+++ b/target/linux/apm821xx/Makefile
@@ -10,6 +10,7 @@ FEATURES:=fpu dt gpio ramdisk squashfs usb
SUBTARGETS:=nand sata
KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
define Target/Description
Build images for AppliedMicro APM821xx based boards.