aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-06-12 11:48:01 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-19 12:31:02 +0200
commit5f7828fcc274ec7c381298c92cf3a946182168a0 (patch)
tree0d28d8d927aa59c18f4b704a8987bd1badb894a3 /target/linux/apm821xx/Makefile
parent6006f73383cc7626552175010de23530bdcc8718 (diff)
downloadupstream-5f7828fcc274ec7c381298c92cf3a946182168a0.tar.gz
upstream-5f7828fcc274ec7c381298c92cf3a946182168a0.tar.bz2
upstream-5f7828fcc274ec7c381298c92cf3a946182168a0.zip
apm821xx: MBL: make mtd chip work
The MBL has a 512KiB Microchip SST39VF040 chip for uboot and not much else. Thanks to Ewald who figured out that the "jedec-probe" vs. "jedec-flash" was the wrong binding. With this information and the jedec-probe support enabled => the chip works. | physmap-flash 4fff80000.nor_flash: physmap platform flash device: [mem 0x4fff80000-0x4ffffffff] | Found: SST 39LF040 | 4fff80000.nor_flash: Found 1 x8 devices at 0x0 in 8-bit bank Suggested-by: Ewald Comhaire <e.comhaire@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/Makefile')
-rw-r--r--target/linux/apm821xx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
index f36274bd98..875ff225a9 100644
--- a/target/linux/apm821xx/Makefile
+++ b/target/linux/apm821xx/Makefile
@@ -21,6 +21,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=uImage
DEFAULT_PACKAGES += \
- kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
+ kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug uboot-envtools
$(eval $(call BuildTarget))