aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amcc-2.6/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
commitdf988938e6316c81a677c259b569363c80dcf7ad (patch)
treee2ffe9308991f4e9b1fb383bc60ce36d28d58376 /target/linux/amcc-2.6/Makefile
parentd6031adcbb8e43a49b0151ed1983738ebde83b63 (diff)
downloadupstream-df988938e6316c81a677c259b569363c80dcf7ad.tar.gz
upstream-df988938e6316c81a677c259b569363c80dcf7ad.tar.bz2
upstream-df988938e6316c81a677c259b569363c80dcf7ad.zip
add support for the AMCC Taishan, mark it as broken until we fix the combined layout
SVN-Revision: 7377
Diffstat (limited to 'target/linux/amcc-2.6/Makefile')
-rw-r--r--target/linux/amcc-2.6/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/amcc-2.6/Makefile b/target/linux/amcc-2.6/Makefile
new file mode 100644
index 0000000000..935e639a53
--- /dev/null
+++ b/target/linux/amcc-2.6/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=amcc
+BOARDNAME:=AMCC Taishan
+FEATURES:=squashfs broken
+
+define Target/Description
+ Build firmware images for the AMCC Taishan evaluation board
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))