aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-11-28 22:17:37 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-11-28 22:17:37 +0000
commit2ee2679ac97098e9cf394ca4e78d2cc6ac5fad85 (patch)
treea94ddbd1439f5a86a7e15ba5c920a1ce039636ba /target/linux/amazon/Makefile
parent9714c8b6425d6fe28b7aac6fbdcb207c05409835 (diff)
downloadupstream-2ee2679ac97098e9cf394ca4e78d2cc6ac5fad85.tar.gz
upstream-2ee2679ac97098e9cf394ca4e78d2cc6ac5fad85.tar.bz2
upstream-2ee2679ac97098e9cf394ca4e78d2cc6ac5fad85.zip
Add kernel 2.6.30 support
The device is booting and Ethernet is working, but nothing more was tested. SVN-Revision: 18589
Diffstat (limited to 'target/linux/amazon/Makefile')
-rw-r--r--target/linux/amazon/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/amazon/Makefile b/target/linux/amazon/Makefile
index cca8a415fa..5a5fed598d 100644
--- a/target/linux/amazon/Makefile
+++ b/target/linux/amazon/Makefile
@@ -18,4 +18,12 @@ define Target/Description
Build firmware images for Infineon Amazon boards
endef
+ifeq ($(KERNEL_PATCHVER),2.6.30)
+ define Kernel/Prepare
+ $(call Kernel/Prepare/Default)
+ mv $(LINUX_DIR)/include/asm-mips/mach-amazon $(LINUX_DIR)/arch/mips/include/asm/mach-amazon
+ mv $(LINUX_DIR)/drivers/char/watchdog/amazon_wdt.c $(LINUX_DIR)/drivers/watchdog/amazon_wdt.c
+ endef
+endif
+
$(eval $(call BuildTarget))