aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-11-28 22:17:37 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-11-28 22:17:37 +0000
commitb1d12c1feb88218b3d60dc61a16380ee09be90a2 (patch)
treef9c0860e6341d2d8c2f4c8f529bf96a6caddc0f5 /target/linux/amazon/Makefile
parentd4f45a44bd71cd5845b53a33097b0ad8d8a5c474 (diff)
downloadupstream-b1d12c1feb88218b3d60dc61a16380ee09be90a2.tar.gz
upstream-b1d12c1feb88218b3d60dc61a16380ee09be90a2.tar.bz2
upstream-b1d12c1feb88218b3d60dc61a16380ee09be90a2.zip
[amazon] Add kernel 2.6.30 support
The device is booting and Ethernet is working, but nothing more was tested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18589 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amazon/Makefile')
-rw-r--r--target/linux/amazon/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/amazon/Makefile b/target/linux/amazon/Makefile
index cca8a415fa..5a5fed598d 100644
--- a/target/linux/amazon/Makefile
+++ b/target/linux/amazon/Makefile
@@ -18,4 +18,12 @@ define Target/Description
Build firmware images for Infineon Amazon boards
endef
+ifeq ($(KERNEL_PATCHVER),2.6.30)
+ define Kernel/Prepare
+ $(call Kernel/Prepare/Default)
+ mv $(LINUX_DIR)/include/asm-mips/mach-amazon $(LINUX_DIR)/arch/mips/include/asm/mach-amazon
+ mv $(LINUX_DIR)/drivers/char/watchdog/amazon_wdt.c $(LINUX_DIR)/drivers/watchdog/amazon_wdt.c
+ endef
+endif
+
$(eval $(call BuildTarget))