aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/patches-3.18/002-adm8668_pci.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-03-28 18:18:38 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-03-28 18:18:38 +0000
commitcdcb00cdde015a776ccee3e2021abde2431eec0b (patch)
treeaf7e7c058267e35959957d08d81172d2d912e65f /target/linux/adm8668/patches-3.18/002-adm8668_pci.patch
parent5dbf2d51cd341da555cad8a12a30f0c7bc8c180a (diff)
downloadupstream-cdcb00cdde015a776ccee3e2021abde2431eec0b.tar.gz
upstream-cdcb00cdde015a776ccee3e2021abde2431eec0b.tar.bz2
upstream-cdcb00cdde015a776ccee3e2021abde2431eec0b.zip
adm8668: add 3.18 support
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45094 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm8668/patches-3.18/002-adm8668_pci.patch')
-rw-r--r--target/linux/adm8668/patches-3.18/002-adm8668_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm8668/patches-3.18/002-adm8668_pci.patch b/target/linux/adm8668/patches-3.18/002-adm8668_pci.patch
new file mode 100644
index 0000000000..70ee00db5a
--- /dev/null
+++ b/target/linux/adm8668/patches-3.18/002-adm8668_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -58,6 +58,7 @@ obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32
+ obj-$(CONFIG_CAVIUM_OCTEON_SOC) += pci-octeon.o pcie-octeon.o
+ obj-$(CONFIG_CPU_XLR) += pci-xlr.o
+ obj-$(CONFIG_CPU_XLP) += pci-xlp.o
++obj-$(CONFIG_ADM8668) += pci-adm8668.o
+
+ ifdef CONFIG_PCI_MSI
+ obj-$(CONFIG_CAVIUM_OCTEON_SOC) += msi-octeon.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1820,6 +1820,9 @@
+
+ #define PCI_VENDOR_ID_CB 0x1307 /* Measurement Computing */
+
++#define PCI_VENDOR_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADM8668 0x8688
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000