aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/image/lzma-loader/src/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:17:43 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commitc35425f4182e90601fa2c2f38b21a54eb49793ad (patch)
tree0b27ba38f5a04ff07e6dedf1b848c953f148e0fd /target/linux/adm8668/image/lzma-loader/src/Makefile
parent2d0a2ff1e0c386bcb3b1ae0a0924624e8cb20b37 (diff)
downloadupstream-c35425f4182e90601fa2c2f38b21a54eb49793ad.tar.gz
upstream-c35425f4182e90601fa2c2f38b21a54eb49793ad.tar.bz2
upstream-c35425f4182e90601fa2c2f38b21a54eb49793ad.zip
adm8668: Remove unmaintained target
This target only supports kernel 3.18, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/adm8668/image/lzma-loader/src/Makefile')
-rw-r--r--target/linux/adm8668/image/lzma-loader/src/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/target/linux/adm8668/image/lzma-loader/src/Makefile b/target/linux/adm8668/image/lzma-loader/src/Makefile
deleted file mode 100644
index 998e390810..0000000000
--- a/target/linux/adm8668/image/lzma-loader/src/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-RAMSTART = 0x80000000
-RAMSIZE = 0x00800000 # 8MB
-LOADADDR = 0x80400000 # RAM start + 4M
-KERNEL_ENTRY = 0x80002000
-
-CROSS_COMPILE = mipsel-openwrt-linux-
-
-OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
-CFLAGS := -I./include -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSTART=${RAMSTART} -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY}
-
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $*.o
-
-CC = $(CROSS_COMPILE)gcc
-LD = $(CROSS_COMPILE)ld
-OBJDUMP = $(CROSS_COMPILE)objdump
-
-O_FORMAT = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
-
-# Drop some uninteresting sections in the kernel.
-# This is only relevant for ELF kernels but doesn't hurt a.out
-drop-sections = .reginfo .mdebug .comment
-strip-flags = $(addprefix --remove-section=,$(drop-sections))
-
-all : lzma.elf lzma.bin
-
-lzma.lds: lzma.lds.in
- sed -e 's,@LOADADDR@,$(LOADADDR),g' $< >$@
-
-kernel.o: vmlinux.lzma lzma.lds
- $(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
-
-lzma.bin: lzma.elf
- $(OBJCOPY) $< $@
-
-lzma.elf: decompress.o stubs.o LzmaDecode.o kernel.o lzma.lds
- $(LD) -T lzma.lds -o $@ $^
-#-s ^
-
-clean:
- rm -f *.o lzma.elf lzma.bin *.tmp *.lds