aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_le
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-09-23 14:56:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-09-23 14:56:29 +0000
commit0f0cd3f0c7f2455faf308643f1deb0158fe21925 (patch)
tree0c7a44c83c9059418c27ef12db4fde06316f9346 /target/linux/adm5120/router_le
parent8db5c02f5f90ac4d15c9e7e5ef2b06c3dcde83c0 (diff)
downloadupstream-0f0cd3f0c7f2455faf308643f1deb0158fe21925.tar.gz
upstream-0f0cd3f0c7f2455faf308643f1deb0158fe21925.tar.bz2
upstream-0f0cd3f0c7f2455faf308643f1deb0158fe21925.zip
[adm5120] experimental support for the Motorola MU Gateway
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12662 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/router_le')
-rw-r--r--target/linux/adm5120/router_le/config-2.6.263
-rw-r--r--target/linux/adm5120/router_le/profiles/Motorola.mk16
2 files changed, 18 insertions, 1 deletions
diff --git a/target/linux/adm5120/router_le/config-2.6.26 b/target/linux/adm5120/router_le/config-2.6.26
index c340a678ad..81d3c39509 100644
--- a/target/linux/adm5120/router_le/config-2.6.26
+++ b/target/linux/adm5120/router_le/config-2.6.26
@@ -14,6 +14,7 @@ CONFIG_ADM5120_MACH_EASY83000=y
CONFIG_ADM5120_MACH_NFS_101=y
CONFIG_ADM5120_MACH_NP27G=y
CONFIG_ADM5120_MACH_NP28G=y
+CONFIG_ADM5120_MACH_PMUGW=y
CONFIG_ADM5120_MACH_RB_11X=y
CONFIG_ADM5120_MACH_RB_133=y
CONFIG_ADM5120_MACH_RB_133C=y
@@ -26,6 +27,7 @@ CONFIG_ADM5120_OEM_COMPEX=y
CONFIG_ADM5120_OEM_EDIMAX=y
CONFIG_ADM5120_OEM_INFINEON=y
CONFIG_ADM5120_OEM_MIKROTIK=y
+CONFIG_ADM5120_OEM_MOTOROLA=y
# CONFIG_ADM5120_OEM_ZYXEL is not set
CONFIG_ADM5120_SOC_BGA=y
CONFIG_ADM5120_WDT=y
@@ -304,7 +306,6 @@ CONFIG_TRAD_SIGNALS=y
CONFIG_USB=m
CONFIG_USB_ADM5120_HCD=m
CONFIG_USB_EHCI_HCD=m
-# CONFIG_USB_ISIGHTFW is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_HCD=m
diff --git a/target/linux/adm5120/router_le/profiles/Motorola.mk b/target/linux/adm5120/router_le/profiles/Motorola.mk
new file mode 100644
index 0000000000..e640b81a1f
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/Motorola.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PMUGW
+ NAME:=Motorola Powerline MU Gateway (EXPERIMENTAL)
+endef
+
+define Profile/PMUGW/Description
+ Package set optimized for the Motorola Powerline MU Gateway board
+endef
+
+$(eval $(call Profile,PMUGW))