aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_le/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /target/linux/adm5120/router_le/profiles
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadupstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'target/linux/adm5120/router_le/profiles')
-rw-r--r--target/linux/adm5120/router_le/profiles/100-Atheros.mk17
-rw-r--r--target/linux/adm5120/router_le/profiles/105-Texas.mk17
-rw-r--r--target/linux/adm5120/router_le/profiles/110-Ralink.mk16
-rw-r--r--target/linux/adm5120/router_le/profiles/200-None.mk17
-rw-r--r--target/linux/adm5120/router_le/profiles/Cellvision.mk16
-rw-r--r--target/linux/adm5120/router_le/profiles/RB1xx.mk17
6 files changed, 100 insertions, 0 deletions
diff --git a/target/linux/adm5120/router_le/profiles/100-Atheros.mk b/target/linux/adm5120/router_le/profiles/100-Atheros.mk
new file mode 100644
index 0000000000..029586848f
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/100-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/adm5120/router_le/profiles/105-Texas.mk b/target/linux/adm5120/router_le/profiles/105-Texas.mk
new file mode 100644
index 0000000000..727a0c0648
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/105-Texas.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+ NAME:=Texas Instruments WiFi
+ PACKAGES:=kmod-acx
+endef
+
+define Profile/Texas/Description
+ Package set compatible with hardware using Texas Instruments WiFi cards
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/adm5120/router_le/profiles/110-Ralink.mk b/target/linux/adm5120/router_le/profiles/110-Ralink.mk
new file mode 100644
index 0000000000..d30ee73944
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/110-Ralink.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink WiFi
+ PACKAGES:=kmod-rt2500
+endef
+
+define Profile/Ralink/Description
+ Package set compatible with hardware using Ralink WiFi cards
+endef
+$(eval $(call Profile,Ralink))
diff --git a/target/linux/adm5120/router_le/profiles/200-None.mk b/target/linux/adm5120/router_le/profiles/200-None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/200-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/adm5120/router_le/profiles/Cellvision.mk b/target/linux/adm5120/router_le/profiles/Cellvision.mk
new file mode 100644
index 0000000000..6912f13e3e
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/Cellvision.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Cellvision
+ NAME:=Cellvision CAS-63x/77x cameras
+ PACKAGES:=kmod-rt2500 kmod-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+endef
+
+define Profile/Cellvision/Description
+ Package set compatible with the Cellvision CAS devices, including Wireless variants.
+endef
+$(eval $(call Profile,Cellvision))
diff --git a/target/linux/adm5120/router_le/profiles/RB1xx.mk b/target/linux/adm5120/router_le/profiles/RB1xx.mk
new file mode 100644
index 0000000000..9dd3de0973
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/RB1xx.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RouterBoard
+ NAME:=RouterBoard RB1xx
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/RouterBoard/Description
+ Package set compatible with the RouterBoard RB1xx devices. Contains RouterOS to OpenWrt\\\
+ installation scripts.
+endef
+$(eval $(call Profile,RouterBoard))