aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-06-17 14:30:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-06-17 14:30:18 +0000
commit845d7e156ebf9dfcff57c629b6511599c96d33c4 (patch)
treef6d66cf37dcff9c1caf8e37d614ef3dfa3947566 /target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
parent7e9b27206f111a18b77a773f091dba5b36b304f6 (diff)
downloadupstream-845d7e156ebf9dfcff57c629b6511599c96d33c4.tar.gz
upstream-845d7e156ebf9dfcff57c629b6511599c96d33c4.tar.bz2
upstream-845d7e156ebf9dfcff57c629b6511599c96d33c4.zip
[adm5120] switch to 2.6.25.7
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch')
-rw-r--r--target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
index fe9c45b092..f5188936da 100644
--- a/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
+++ b/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
@@ -1,8 +1,8 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -160,6 +160,22 @@
- for your particular device. It won't happen automatically. The
- 'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
+@@ -168,6 +168,22 @@
+ the partition map from the children of the flash node,
+ as described in Documentation/powerpc/booting-without-of.txt.
+config MTD_MYLOADER_PARTS
+ tristate "MyLoader partition parsing"
@@ -25,10 +25,10 @@
config MTD_CHAR
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -11,6 +11,7 @@
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+@@ -12,6 +12,7 @@
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
# 'Users' - code which presents functionality to userspace.