aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches/005-adm5120_usb.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
commitd187aba072246a4b03979b52b63198967cb511e6 (patch)
tree0e564d4fff61a6173e95cf1e26ff005dd47a5fa4 /target/linux/adm5120/patches/005-adm5120_usb.patch
parentcf02f1c6b20c64b88d51d0d6d5324ea6010583c7 (diff)
downloadupstream-d187aba072246a4b03979b52b63198967cb511e6.tar.gz
upstream-d187aba072246a4b03979b52b63198967cb511e6.tar.bz2
upstream-d187aba072246a4b03979b52b63198967cb511e6.zip
switch to 2.6.24
SVN-Revision: 10427
Diffstat (limited to 'target/linux/adm5120/patches/005-adm5120_usb.patch')
-rw-r--r--target/linux/adm5120/patches/005-adm5120_usb.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches/005-adm5120_usb.patch b/target/linux/adm5120/patches/005-adm5120_usb.patch
new file mode 100644
index 0000000000..a2e43b4f66
--- /dev/null
+++ b/target/linux/adm5120/patches/005-adm5120_usb.patch
@@ -0,0 +1,35 @@
+Index: linux-2.6.24/drivers/usb/host/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/usb/host/Kconfig
++++ linux-2.6.24/drivers/usb/host/Kconfig
+@@ -261,3 +261,6 @@ config USB_R8A66597_HCD
+ To compile this driver as a module, choose M here: the
+ module will be called r8a66597-hcd.
+
++config USB_ADM5120_HCD
++ tristate "ADM5120 HCD support (EXPERIMENTAL)"
++ depends on USB && MIPS_ADM5120 && EXPERIMENTAL
+Index: linux-2.6.24/drivers/usb/host/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/usb/host/Makefile
++++ linux-2.6.24/drivers/usb/host/Makefile
+@@ -8,6 +8,7 @@ endif
+
+ obj-$(CONFIG_PCI) += pci-quirks.o
+
++obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
+ obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
+Index: linux-2.6.24/drivers/usb/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/usb/Makefile
++++ linux-2.6.24/drivers/usb/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
+ obj-$(CONFIG_USB_SL811_HCD) += host/
+ obj-$(CONFIG_USB_U132_HCD) += host/
+ obj-$(CONFIG_USB_R8A66597_HCD) += host/
++obj-$(CONFIG_USB_ADM5120_HCD) += host/
+
+ obj-$(CONFIG_USB_ACM) += class/
+ obj-$(CONFIG_USB_PRINTER) += class/