aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-24 18:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-24 18:08:14 +0000
commit05de472518d8ae3504cd132069ce29c27cb934d4 (patch)
tree6aec7f7cca1627628c736f223bd1b5a3da89a05a /target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch
parent3d65d0291c0b55b44fd9fa1c54ae01938ced9191 (diff)
downloadupstream-05de472518d8ae3504cd132069ce29c27cb934d4.tar.gz
upstream-05de472518d8ae3504cd132069ce29c27cb934d4.tar.bz2
upstream-05de472518d8ae3504cd132069ce29c27cb934d4.zip
adm5120: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35769
Diffstat (limited to 'target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..08fecd8e9e
--- /dev/null
+++ b/target/linux/adm5120/patches-3.8/103-mtd_trxsplit.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -31,6 +31,10 @@ config MTD_ROOTFS_SPLIT
+ bool "Automatically split 'rootfs' partition for squashfs"
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o