aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.8/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-24 18:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-24 18:08:14 +0000
commit05de472518d8ae3504cd132069ce29c27cb934d4 (patch)
tree6aec7f7cca1627628c736f223bd1b5a3da89a05a /target/linux/adm5120/patches-3.8/007-adm5120_pci.patch
parent3d65d0291c0b55b44fd9fa1c54ae01938ced9191 (diff)
downloadupstream-05de472518d8ae3504cd132069ce29c27cb934d4.tar.gz
upstream-05de472518d8ae3504cd132069ce29c27cb934d4.tar.bz2
upstream-05de472518d8ae3504cd132069ce29c27cb934d4.zip
adm5120: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35769
Diffstat (limited to 'target/linux/adm5120/patches-3.8/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-3.8/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.8/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.8/007-adm5120_pci.patch
new file mode 100644
index 0000000000..2930884d1e
--- /dev/null
+++ b/target/linux/adm5120/patches-3.8/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
+ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
+ ops-bcm63xx.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+ obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
+ obj-$(CONFIG_PCI_AR724X) += pci-ar724x.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1807,6 +1807,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000