aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:49 +0000
commitd91117459c1536173ed71f3a4f64e5d4603aac4b (patch)
tree343842801a198e7b56b22748fa3c954b43513a17 /target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch
parentf0520f1714404ebb326ba78a0c731ffbe25a7bc8 (diff)
downloadupstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.tar.gz
upstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.tar.bz2
upstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.zip
adm5120: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34954
Diffstat (limited to 'target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..08fecd8e9e
--- /dev/null
+++ b/target/linux/adm5120/patches-3.7/103-mtd_trxsplit.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -31,6 +31,10 @@ config MTD_ROOTFS_SPLIT
+ bool "Automatically split 'rootfs' partition for squashfs"
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o