aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.7/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:49 +0000
commitd91117459c1536173ed71f3a4f64e5d4603aac4b (patch)
tree343842801a198e7b56b22748fa3c954b43513a17 /target/linux/adm5120/patches-3.7/007-adm5120_pci.patch
parentf0520f1714404ebb326ba78a0c731ffbe25a7bc8 (diff)
downloadupstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.tar.gz
upstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.tar.bz2
upstream-d91117459c1536173ed71f3a4f64e5d4603aac4b.zip
adm5120: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34954
Diffstat (limited to 'target/linux/adm5120/patches-3.7/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-3.7/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.7/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.7/007-adm5120_pci.patch
new file mode 100644
index 0000000000..c0b8756f6c
--- /dev/null
+++ b/target/linux/adm5120/patches-3.7/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
+ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
+ ops-bcm63xx.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+ obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
+ obj-$(CONFIG_PCI_AR724X) += pci-ar724x.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1806,6 +1806,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000