aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-01 13:15:36 +0000
commite28e4f21bb2a1c67c9f060ed6a02ae96357671a3 (patch)
tree22ba0a510477e54f3ef59cae235649422eb9b474 /target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
parent1bb315c9c02228af26d6df497be29ba04630b213 (diff)
downloadupstream-e28e4f21bb2a1c67c9f060ed6a02ae96357671a3.tar.gz
upstream-e28e4f21bb2a1c67c9f060ed6a02ae96357671a3.tar.bz2
upstream-e28e4f21bb2a1c67c9f060ed6a02ae96357671a3.zip
adm5120: add support for 3.6
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34951 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..c89e326bab
--- /dev/null
+++ b/target/linux/adm5120/patches-3.6/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -555,4 +555,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -66,3 +66,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o