aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
commit3b21b2ae00c8e354db1789f8be5235a8fcb7a623 (patch)
tree379f0d688f6caf3cd9a33056dbca9362c1f36b7a /target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch
parentc119814b2bf25bc89a5cbfb3eb791ad7461d0c38 (diff)
downloadupstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.gz
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.bz2
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.zip
adm5120: add experimental 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43915
Diffstat (limited to 'target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..62667769cd
--- /dev/null
+++ b/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -60,6 +60,10 @@ config MTD_ROOTFS_SPLIT
+ bool "Automatically split 'rootfs' partition for squashfs"
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o