aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
commit3b21b2ae00c8e354db1789f8be5235a8fcb7a623 (patch)
tree379f0d688f6caf3cd9a33056dbca9362c1f36b7a /target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
parentc119814b2bf25bc89a5cbfb3eb791ad7461d0c38 (diff)
downloadupstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.gz
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.bz2
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.zip
adm5120: add experimental 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43915
Diffstat (limited to 'target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..698b66908c
--- /dev/null
+++ b/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -490,4 +490,12 @@ config LEDS_BLINKM
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -63,3 +63,4 @@ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o