aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
commit7cb70cb2b8f2b3e31d3e86576141abb161593fb6 (patch)
tree66996ea1e9ed75cda833e663a45805a1e804360d /target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch
parent8ae1a4fc69b0155cd30b7d39977f782c1046e477 (diff)
downloadupstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.gz
upstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.bz2
upstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.zip
linux/adm5120: add preliminary 2.6.36 kernel support (refresh patches)
SVN-Revision: 23224
Diffstat (limited to 'target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..23cc54d514
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.36/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -848,6 +848,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -110,6 +110,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
+ # MIPS Architecture
+ obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
+ obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o