aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-12-22 17:19:36 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-12-22 17:19:36 +0000
commita43801cfd8771d232c665b844d597899403944aa (patch)
tree36af13172be38e491bf935a88f78427d11c0120a /target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
parentb5645d890cf7fcadbdf15da50daf5be3fc67f67b (diff)
downloadupstream-a43801cfd8771d232c665b844d597899403944aa.tar.gz
upstream-a43801cfd8771d232c665b844d597899403944aa.tar.bz2
upstream-a43801cfd8771d232c665b844d597899403944aa.zip
adm5120: make patches apply again and refresh them
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24800 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
index a52dfac7a8..f8e550d9f8 100644
--- a/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -391,4 +391,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -398,4 +398,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o