aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
commitd3c1b29b8f7e966cd5eefe25747713eddcf5e993 (patch)
tree31dd28609228bbd8419b0f1a48dbb4fb7058e8eb /target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
parent93df40258982e2bf69bb0b1712a2a96c10c6c56a (diff)
downloadupstream-d3c1b29b8f7e966cd5eefe25747713eddcf5e993.tar.gz
upstream-d3c1b29b8f7e966cd5eefe25747713eddcf5e993.tar.bz2
upstream-d3c1b29b8f7e966cd5eefe25747713eddcf5e993.zip
adm5120: add kernel 2.6.35 preliminary support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21751 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
new file mode 100644
index 0000000000..fb5fb83127
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.35/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -614,6 +614,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -213,6 +213,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o