aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit066358ab8036321a9c333a881ba329985e688dfd (patch)
tree4d6a6ef78043d87b6da5d7cbfd5a51d744e5f205 /target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch
parentcde7b6363c77be3d6e81e9444ac5d2ba8d0db87f (diff)
downloadupstream-066358ab8036321a9c333a881ba329985e688dfd.tar.gz
upstream-066358ab8036321a9c333a881ba329985e688dfd.tar.bz2
upstream-066358ab8036321a9c333a881ba329985e688dfd.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
SVN-Revision: 21182
Diffstat (limited to 'target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..b7833c72a7
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -790,6 +790,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -113,6 +113,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+
+ # PARISC Architecture
+