aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit535270a5d43ad39e41c23272b5a2e8c654f9c7f7 (patch)
treeaa238bd29ae75fe2f49e391bbb1c60e934a6f8da /target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
parentc3849fdfbdcab7486a1004833cb3594548f18b77 (diff)
downloadupstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.gz
upstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.bz2
upstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..69f1035505
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.33/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o