aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
commit89f3773ca4b4e278728ccf83e29e5bf117484663 (patch)
tree6bf5f02cf46042e7e0d8064dbb3352aec869adce /target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch
parente16f20b51813c4ef7d2519235d45fa37bd09e2ac (diff)
downloadupstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.gz
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.bz2
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.zip
adm5120: preliminary 2.6.32 support (closes: #6304)
SVN-Revision: 19005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..b7833c72a7
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.32/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -790,6 +790,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -113,6 +113,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+
+ # PARISC Architecture
+