aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
commit89f3773ca4b4e278728ccf83e29e5bf117484663 (patch)
tree6bf5f02cf46042e7e0d8064dbb3352aec869adce /target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
parente16f20b51813c4ef7d2519235d45fa37bd09e2ac (diff)
downloadupstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.gz
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.bz2
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.zip
adm5120: preliminary 2.6.32 support (closes: #6304)
SVN-Revision: 19005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..272fb8f19c
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -315,4 +315,12 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -42,3 +42,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o