aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-10-08 11:13:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-10-08 11:13:10 +0000
commite4c19ed21530b07cc3a7ddab37876b19c8f95498 (patch)
treedf1f05cf3158fa2f762934008e238816bdf2df90 /target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
parent3d03666521e6b8062bd89244d8c8dcea0e3a8e11 (diff)
downloadupstream-e4c19ed21530b07cc3a7ddab37876b19c8f95498.tar.gz
upstream-e4c19ed21530b07cc3a7ddab37876b19c8f95498.tar.bz2
upstream-e4c19ed21530b07cc3a7ddab37876b19c8f95498.zip
adm5120: add preliminary support for 2.6.31
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18000 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..6fe5f3b3fc
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -308,4 +308,12 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -41,3 +41,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o