aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
commitd31a7b51abc91241870e907ff76ce7058aceefa1 (patch)
tree920f2dabb56d1bae95a670b63ff37ef2ae33f68f /target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch
parentc28af661ee0a71d7964358a41d19dcc86737f19b (diff)
downloadupstream-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.gz
upstream-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.bz2
upstream-d31a7b51abc91241870e907ff76ce7058aceefa1.zip
add experimental support for 2.6.30
SVN-Revision: 15979
Diffstat (limited to 'target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch
new file mode 100644
index 0000000000..97f5b96cc2
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.30/002-adm5120_flash.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -562,4 +562,8 @@ config MTD_VMU
+ To build this as a module select M here, the module will be called
+ vmu-flash.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on ADM5120
++
+ endmenu
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o