aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit4e8b080d9f7819ee9bb77cdb8215462acc1759f9 (patch)
treeefad7bd1b41a2d96ff842eaa6ef2c5f241ff943d /target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch
parent9a74dd2faae85d00c5e669fce947aec8eb1f0dfb (diff)
downloadupstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.gz
upstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.bz2
upstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.zip
preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
SVN-Revision: 14189
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..d3b0858040
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -55,6 +55,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o